Application Service Unavailability

Incident Report for Patlytics

Postmortem

What happened

On 2026-08-17, between approximately 21:00 and 21:20 UTC, a routine software update introduced a misconfiguration which incorrectly pinned the execution of a piece of server software to the browser.

As a result, loading Patlytics in the browser displayed a generic error screen instead of the application. No data was lost, exposed, or altered, and no background processing (report generation, analysis jobs, or integrations) was affected.

Who was affected

The issue affected new page loads only. Users who already had Patlytics open in a browser continued working without interruption for the duration of the window; our usage telemetry shows normal levels of in-session activity throughout the incident period. Users who opened, reloaded, or returned to the application during the roughly 20-minute window would have seen the error screen and been unable to proceed until the fix was applied.

The impact was limited to the web interface. API access and asynchronous jobs processing (including report generation) were unaffected.

What we did

Internal users were the first to report the issue to our Engineering team and service was restored immediately via roll back. The rollback landed at approximately 21:20 UTC, and normal page loads resumed immediately.

What we're doing to prevent this from happening again

We have made the following changes to our release process and monitoring:

  • Automated browser-level testing for changes that touch application configuration and startup code. Although storybook and unit tests exist, these failed to capture this type of defect.
  • Improved monitoring for total page-load failures. Because the failure occurred before our client-side monitoring could initialize, it produced no error telemetry. We have added independent monitoring that detects a drop in successful page loads directly, so this class of outage is caught by alerting rather than by user report.

We hold ourselves to a high standard of reliability, and we apologize for the disruption. Please reach out to your Patlytics contact, or message us through the in-app support widget, with any questions.

Posted Aug 27, 2026 - 10:20 EDT

Resolved

A misconfiguration caused fresh application loads to crash resulting in an error page being served. Users who already had the application loaded were unaffected.
Posted Aug 17, 2026 - 21:00 EDT